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Video taping the lecture 
 

 

1. When video taping the lecture, you will have to do the below.  

・ Video taping with a video camera 

・ Taking the timing of the slide 

 

2. Video taping with video camera 

When videotaping the lecture, please videotape lecture’s video/audio, and student’s video/ audio.  

Basically, you will videotape lecturer ’s talk, and student’s environment during question and answer 

session.  PowerPoint slide, white board and black board will be put into web page, so you don’t 

need to videotape those things.  Basic AV connection is like below. 

 

Videotape the lecture and encode the video to Realvideo (http://www.real.com/) format. Videotape 

with VCR, and also with the video camera as backup.  The format can be anything such as DV or 

8mm or VHS. 

 

3. Taking the timing of the slide  

You will have to need the PowerPoint slide timing file for making the web based materials 

later.  You will need the timing file to synchronize the video and PowerPoint.  There are 2 soft 

wares to make timing data files. 

 

o RPT 

This tool automatically takes the timing of the PowerPoint.  Usually, this software is 

installed to lecturer ’s laptop computers.   



o TRecoder  

This tool takes the timing of the PowerPoint by hand.  Usually, this software is installed 

to staff PC and takes the timing file by hand.   

 



Video Encoding Manual 
 

 

1. Prepare DV tapes 

 Connect your PC and VCR to encode your videotape. 

 

2. Launch Helix Producer 

 You will see below picture when you launch the Helix producer.   

 
3. Change your view window. 

Put the “Output Video” check “OFF” from the View menu to reduce CPU usage. 

(If the CPU usage gets near to 100%, please check off the “Output Audio Meter”, too) 



 

4. Select your device 

Choose your video and audio devise. 

 

5. Set your audience 

Push “Audience button and select your desired audience”.  Below is the example of 

SOI configuration 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 



Select option -> property 

6. Check Sound 

 Start the volume control property in the task bar of your windows system by 

double clicking the icon.  Select [Option] -> [Property] and [Recording]. 

 

Audio property 

 

 

 

 

New dialog will open as you click “OK”, so please check Line In is selected. 

 

Here, start the DV set to play the DV tape, and start encoding.  Please check video is 

playing at the left window, and audio level is OK at your Real Producer screen.  When 

checking is done, please push Stop. 

 

4. Start encoding  

 

 Rewind the tape and start encoding.  When starting, if you don’t start 

encoding start button then play the video, so that you can see that complete video is 

encoded. 

 

5. Finish encoding 

 

 When encoding is done, Push STOP button to stop.  It takes a little bit time to 

write the video to HDD. 

 

7. Confirmation 

 Double click your encoded RealVideo file and see the length and audio level of 

your encoded video. 



How to use SOI RPT 
 
 

1. RPT installed in laptop at distance classroom  

RPT is a windows system software. Please install in a windows system to use RPT.  

You need to install the power point file lecturer use, then start the RPT and input the PPT file.  

The power point starts the slide show as the lecturer does in the real classroom.  

 

2. RPT environment 

Windows95/98/2000 + Office2000  

 

3. Installation (install 2 files below)  

RPT.exe : http://www.soi.wide.ad.jp/pub/software/RPT/static/RPT.exe 

It might be easier if you make a directory "C:¥Program Files¥soibeans¥"  

RPTHook.dll : http://www.soi.wide.ad.jp/pub/software/RPT/static/RPTHook.dll 

Install this file into "C:¥WINNT¥system32"  

 

4. Preparation  

 Get a Power Point file of the lecturer before you start RPT  

 

5. How to use RPT  

 

(1) Start PowerPoint and open the PowerPoint file.  

(2)Start RPT.exe  

Especially with Windows95, you have to start PowerPoint, then RPT. Otherwise, it will get 

errors and won't go well(In case of Windows2000, the order doesn't matter.).  

(3)You will get a pop up window "Connect IRC Server", configure as below. 

 

 



    Server   : irc.kyoto.wide.ad.jp 

    Port     : 6667 

    Channel  : #soi-rpt 

    Nickname : your name 

    Password : karaage 

 

    Don't select URL and Send Message if you are not the lecturer. 

    select [connect] 

If you are not using RPT to share with distant classroom, you don’t have to connect to the 

IRC server. 

(4) Check “Save Timing File” 

(5) Select [file] -> [Open timing file] from the menu.  You can select the name of timing file. 

(6) Open PPT file from the menu. 

(7)Select [Start] 

 

   
 

 



How to make SOI Materials 
 

 

STEP1. Required environment 

 

Before starting to make the materials, please do the following. 

(1) Operating environment 

Windows98/2000 + Office2000  

(2) Installation 

Download the 3 softwares (P2H, TRecorder, Real Player8), and install them. 

( It might be nicer if you make "soibeans" folder and place the softwares in that folder. ) 

 

P2H 
This tool is for making HTML files from PowerPoint. 

http://www.soi.wide.ad.jp/pub/software/P2H/ 

TRecorder 
TRecoder  This tool is for making SMIL files from timing file. 

http://www.soi.wide.ad.jp/pub/software/TRecoder/ 

RealPlayer8 
This tool is for playing the video. 

http://www.real.com/download/ 

 

 

STEP2. Get required data 

 

Get the following 5 files from a person in charge of the lecture.  

 Material used in the lecture(*.ppt)  

Slide timing file recorded in the lecture(*.trt)  

HTML template file(*.html)  

IndexHTML template file(*-index.html)  

Encoded Video  

 

You can save those required data anywhere.  However, if you save it like this how to do STEP1, 

and make "soi" folder and "data" sub folder for materials, it is easier to save data in a neat way.  

example) Folders like "01" in STEP3 can be saved under "soi" folder  

 

 

 

 



STEP3. Making HTML and IMG files 

 

Please make HTML and IMG files according to the manual below. 

 

(1) Preparation 

l Open PowerPoint and Timing file. 

( You can open Timing file with notepad or some editor.) 

l Arrange the PowerPoint file (*.ppt) to go with the Timing file. 

(Attention)If the number of PowerPoint slides and timing does not match, the video 

will not work properly. 

l Make a folder according to a order number of the class (ex. 01), so that you can save 

the files you will make.   Next, please make "img_rp" folder under the class folder 

you made just before. (ex. 01¥img_rp) 

 

(2) To make SOI based HTML  

l Start P2H (PowerPoint will be automatically start, too.) 

Select 'File' -> 'Open PPT File' , and select the ppt file you will be using. 

l Select 'File' -> 'Save Location' , and locate a place where html and img files will be 

saved.  

Select the class id folder which was made in STEP3 3,4 (ex. "01"). 

l Select "SOI HTML" 

l Push "Export" 

l Select IndexHTML template file (*-index.html) 

l This is included in the files you will get from the manager of the lecture.  

l Select HTML template file (*.html) 

l This is included in the files you will get from the manager of the lecture.  

l You will see a dialog box saying "Do you want archive to TAR file?", so answer "no", 

if you do not need it.  

l Detailed information of 4-11 with pictures is here. 

 

(3) Make img files for RealPix  

l Select 'File' -> 'Save Location', and locate a place to save img files.  

You can choose "img_rp" folder that you made in STEP3 3,4(ex.01¥img_rp). 

l Select 'Image' 

l Select 'PNG', [ width 320/ height 240 ]. 

l Push 'Export' 



l You will see a dialog box saying "Do you want archive to TAR file?", so select "no" if 

you do not need them. 

 

STEP4: Making SMIL files 

 

l Start TRecoder.  

l Select 'File' -> 'open', and choose the timing file you have modified in STEP3(*.trt). 

l If there are differences between RealVideo file and Timing file, modify the timing 

file.  

ex. If you want to delay 5th timing for 10 seconds,  

Choose No.'5' - No.'5' '0'min. '10'sec. 'Add' and push 'Modify' 

 

ex. If the starting time of the RealVideo is 5 seconds late than the timing file ; You 

should delay the timing file for 5 seconds. 

Choose No.'1' - No.'30' '0'min. '5'sec.'Add' and push 'Modify' 

 

ex. If the starting time of the RealVideo is 5 seconds early than the timing file ; You 

should modify the timinf file 5 seconds earlier. 

Choose No.'1' - No.'30' '0'min. '5'sec. 'Reduce' and push 'Modify' 

 

(Attention)If you want to change the timing file from 1 line to 1 line, please start from 

the end of the file. 

If you see a Error (wrong value set), check it if the timing value is back and forth or 

not. 

l When the modification is done, push 'Export' 

l Fill in needed information for making SMIL file. 

 

'ID'  

ID number of the class (ex. 5th class -> 05) 

 

'Title'  

class ID (ex. Network Architecture -> 20010012) 

 

'Copyright'  

ex.(C) 2001 School of Internet  

 



'URI(SMIL)'  

Location of the SMIL file  

(ex. rtsp://stream.soi.wide.ad.jp/soi/class/'class ID'/slides/number of the class ->  

rtsp://stream.soi.wide.ad.jp/soi/class/20000001/slides/05 )  

 

'URI(RM)'  

Location of the video 

(ex. rtsp://stream.soi.wide.ad.jp/soi/class/'class id'/video/'number of the class'/'number of the 

class'.rm -> rtsp://stream.soi.wide.ad.jp/soi/class/20000001/video/05/05.rm ) 

 

Check 'Insert URL link'  

'URI(HTTP)' 

Location of the HTML file  

(ex. http://www.soi.wide.ad.jp/class/'class id'/slides/'lecture id' ->  

http://www.soi.wide.ad.jp/class/20000001/slides/01 ) 

 

'End Time' 

End time of the Video (ex.01:28:30)  

'Bitrate' 

bitrate of the RealPix (ex. 3000)  

'Image Ext.'  

extention of the img file. Choose PNG.  

'Image Dir. '  

Directory name of the PNG file. Fill in img_rp.  

'Width/Height'  

Window size which includes RealPix and video. (Fill in Width:640, Height:240)   

 

l Select the foleder you made in STEP4 2.(ex.01) for saving the SMIL file. 

l Push 'OK'. 

 

You will see a dialog saying "Do you want archive to TAR file?", please answer "YES" and save it in 

TAR style file. If you do not have tools like ftp client, making TAR file is easier, but if you have one, 

you do not need to make TAR style file. 

 

 

 



STEP5: Put the files you made to the server.  

 

l Put the files you made in STEP4,5 onto the designated server.  

Please put all the files you made in STEP4. 

Upload the TAR file and extract it on the server, or ftp every file you made directly 

onto the server.  

*.html  

index_*.html  

img/*.png, img_rp/*.PNG  

*.smi  

*.ram  

l Please save each modified PowerPoint somewhere, so that you can retrieve it when 

needed.  

 

STEP6: confirm the contents 

l Start WEB client and check if you can see a intended class page. 

If you have correction to make, go back some steps and correct it. 

l Check the HTML and PNG file.  

l Run the RealVideo file and check if you can see both RealPix and video.  

l Check the timing of the slide change.  

 

 



How to use P2H 
 

 

1. Preparation 

Install P2H to your local PC 

http://www.soi.wide.ad.jp/pub/soibeans/P2H/ 

2. Start P2H (PowerPoint will automatically start, too) 

Saving place should be under class number folder you have made. 

 

 

3. Select [File] -> [Open PPT File], and choose PowerPoint file used at the lecture. 

(If you have opened the PowerPoint file before starting P2H, you do not need to do this) 

 
 



4. Select [File] -> [Save Location], and choose the place to save your html files. 

Saving place should be under class number folder you have made. 

5. Select [SOI HTML] 

6. Push [Export] 

You will be asked “Do you want to write index.html?” in the dialog, so answer YES. 

Select template file of the IndexHTML(*-index.html) 

Select template file of the HTML (*.html) 

7.  You will be asked “Do you want archive to TAR file?”, so answer “NO” 

 

8.  From here, you will be making just picture files. 

9.  Select [File] -> [Save location], and choose the place that the pictures will be saved. 

    You can use “img_rp” folder you have prepared before. 

10. Select [Image] 

11. Select [PNG],  Width[320], Height[240] 

 
12. Push [Export] 

13. You will be asked “Do you want archive to TAR file?”, so answer “NO” 



Making SOI contents to CD-ROM 

 

1. Preparation 

  Copy icon_tv.GIF and icon_pencil.gif to your local directory 

#mount  /mnt/cdrom/ 

#cp icon_tv.GIF /soi/soi/picture/ 

#cp icon_pencil.gif /soi/soi/picture/ 

  Copy CD making script to your local directory 

  #cp mk_lecture_cd.pl /soi/soi/util/ 

#chmod 755 /soi/soi/util/mk_ lecture _cd.pl 

2. Create directory for making CD 

%mkdir /home/funya/CD 

3. Change directory to CD 

%cd /home/funya/CD/ 

4. Run CD making script 

        % /soi/soi/util/mk_lecture_cd.pl  

          Lecture Dir (Example: /soi/soi/class/20020032/slides/01/)? *** 

 

 Fill in lecture material directory at *** 

        ex. /soi/soi/class/20020032/slides/01/ 

5. Put real video to the CD directory 

        % cp /soi/soi/class/20020032/video/01/01.rm . 

6. Burn the directory to a CD 

Download the CD directory to your local PC. 

Burn all the contents to a CD 

Check the CD by clicking index.html in the CD 

 


